Powered by OpenAIRE graph
Found an issue? Give us feedback
image/svg+xml Jakob Voss, based on art designer at PLoS, modified by Wikipedia users Nina and Beao Closed Access logo, derived from PLoS Open Access logo. This version with transparent background. http://commons.wikimedia.org/wiki/File:Closed_Access_logo_transparent.svg Jakob Voss, based on art designer at PLoS, modified by Wikipedia users Nina and Beao Digitální knihovna V...arrow_drop_down
image/svg+xml Jakob Voss, based on art designer at PLoS, modified by Wikipedia users Nina and Beao Closed Access logo, derived from PLoS Open Access logo. This version with transparent background. http://commons.wikimedia.org/wiki/File:Closed_Access_logo_transparent.svg Jakob Voss, based on art designer at PLoS, modified by Wikipedia users Nina and Beao
addClaim

Mobile IPv6 v prostředí OPNET Modeler

Authors: Žáček, Martin;

Mobile IPv6 v prostředí OPNET Modeler

Abstract

Master’s thesis includes knowledges about mobility support in IPv4 networks and studies abilities for mobility support in IPv6 networks. Describes protocols for mobility support, their functions and topologies like MIPv6 (RFC 3775), FMIPv6 (RFC 5568), HMIPv6 (RFC 5380) and F-HMIPv6. The thesis contains a design of the simulation MIPv6 in the OPNET Modeler program and the measured results are explained. There are analysis of source code for mobility support in MIPv6 too, which were used for design a new protocol according to FMIPv6 in the OPNET. The following parts of the proposal have been successfully resolved. The link-layer events detection, which triggers FMIPv6 protocol and implementation of two new types of messages, RtSolPr and PrRtAdv. Knowledges from this thesis could be used for next development of FMIPv6 in the OPNET. But could be used for generaly development new protocols working at network-layer too.

Diplomová práce shrnuje poznatky o podpoře mobility v IPv4 sítích a detailně prozkoumává možnosti mobility v IPv6 sítích. Jsou zde popsány funkce a topologie protokolů MIPv6 (RFC 3775), FMIPv6 (RFC 5568), HMIPv6 (RFC 5380) a F-HMIPv6. Dále práce obsahuje návrh simulace MIPv6 v prostředí OPNET Modeler a diskuzi výsledků k této simulaci. V neposlední řade, byla provedena analýza zdrojových kódů programu OPNET, pro účely návrhu vlastního protokolu pro podporu mobility, dle FMIPv6. V implementaci FMIPv6 se podařila vyřešit detekce událostí z linkové vrstvy, které slouží ke spouštění vlastního protokolu a byly implementovány dvě zprávy RtSolPr a PrRtAdv. Poznatky z této práce mohou sloužit k dokončení implementace protokolu FMIPv6 v prostředí OPNET, ale také mohou být využity obecně jako metodika práce při návrhu nových typů zpráv přenášených na síťové vrstvě v IPv6 síti.

A

Country
Czech Republic
Related Organizations
Keywords

PROTOCOL, NÁVRH, DESIGN, MOBILITY, MIPV6, SIMULATION, PROTOKOL, MOBILITA, FMIPV6, SIMULACE, OPNET

  • BIP!
    Impact byBIP!
    selected citations
    These citations are derived from selected sources.
    This is an alternative to the "Influence" indicator, which also reflects the overall/total impact of an article in the research community at large, based on the underlying citation network (diachronically).
    0
    popularity
    This indicator reflects the "current" impact/attention (the "hype") of an article in the research community at large, based on the underlying citation network.
    Average
    influence
    This indicator reflects the overall/total impact of an article in the research community at large, based on the underlying citation network (diachronically).
    Average
    impulse
    This indicator reflects the initial momentum of an article directly after its publication, based on the underlying citation network.
    Average
Powered by OpenAIRE graph
Found an issue? Give us feedback
selected citations
These citations are derived from selected sources.
This is an alternative to the "Influence" indicator, which also reflects the overall/total impact of an article in the research community at large, based on the underlying citation network (diachronically).
BIP!Citations provided by BIP!
popularity
This indicator reflects the "current" impact/attention (the "hype") of an article in the research community at large, based on the underlying citation network.
BIP!Popularity provided by BIP!
influence
This indicator reflects the overall/total impact of an article in the research community at large, based on the underlying citation network (diachronically).
BIP!Influence provided by BIP!
impulse
This indicator reflects the initial momentum of an article directly after its publication, based on the underlying citation network.
BIP!Impulse provided by BIP!
0
Average
Average
Average
Upload OA version
Are you the author of this publication? Upload your Open Access version to Zenodo!
It’s fast and easy, just two clicks!